import re
regex = re.compile(r"""
\{(?:[^{}]|(?R))*\}
""", flags=re.VERBOSE)
test_str = ("This is a funny text about stuff,\n"
"look at this product {\"action\":\"product\",\"options\":{...}}.\n"
"More Text is to come and another JSON string\n"
"{\"action\":\"review\",\"options\":{...}}")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")