re = /\{(?:[^{}]|(?R))*\}/x
str = 'This is a funny text about stuff,
look at this product {"action":"product","options":{...}}.
More Text is to come and another JSON string
{"action":"review","options":{...}}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end