import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\{(?:[^\\{\\}]|(?R))*\\}";
final String string = "This is a funny text about stuff,\n"
+ "look at this product {\"action\":\"product\",\"options\":{...}}.\n"
+ "More Text is to come and another JSON string\n"
+ "{\"action\":\"review\",\"options\":{...}}";
final Pattern pattern = Pattern.compile(regex, Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}