#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?:IF|ELSE) ([A-Z]+) -> ([A-Z]+) IN\(( (?:"[A-Z0-9]{2}"(?:[, ])*)+)\)(?: +)THEN ([A-Z0-9\-]+) ="([A-Z]+)""
Local $sString = "IF KNVV -> KDGRP IN( "EK", "ES" ) THEN KNA1-SORTL ="KA"" & @CRLF & _
"ELSE KNVV -> KDGRP IN( "EL", "E3", "E5", "E7", "E2", "EF" ) THEN KNA1-SORTL ="IN"" & @CRLF & _
"ELSE KNVV -> KDGRP IN( "EX", "EU", "EV", "ET", "EW" ) THEN KNA1-SORTL ="CA"" & @CRLF & _
"END"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")