using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:IF|ELSE) ([A-Z]+) -> ([A-Z]+) IN\(( (?:""[A-Z0-9]{2}""(?:[, ])*)+)\)(?: +)THEN ([A-Z0-9\-]+) =""([A-Z]+)""";
string input = @"IF KNVV -> KDGRP IN( ""EK"", ""ES"" ) THEN KNA1-SORTL =""KA""
ELSE KNVV -> KDGRP IN( ""EL"", ""E3"", ""E5"", ""E7"", ""E2"", ""EF"" ) THEN KNA1-SORTL =""IN""
ELSE KNVV -> KDGRP IN( ""EX"", ""EU"", ""EV"", ""ET"", ""EW"" ) THEN KNA1-SORTL =""CA""
END";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}