import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:IF|ELSE) ([A-Z]+) -> ([A-Z]+) IN\\(( (?:\"[A-Z0-9]{2}\"(?:[, ])*)+)\\)(?: +)THEN ([A-Z0-9\\-]+) =\"([A-Z]+)\"";
final String string = "IF KNVV -> KDGRP IN( \"EK\", \"ES\" ) THEN KNA1-SORTL =\"KA\"\n"
+ "ELSE KNVV -> KDGRP IN( \"EL\", \"E3\", \"E5\", \"E7\", \"E2\", \"EF\" ) THEN KNA1-SORTL =\"IN\"\n"
+ "ELSE KNVV -> KDGRP IN( \"EX\", \"EU\", \"EV\", \"ET\", \"EW\" ) THEN KNA1-SORTL =\"CA\"\n"
+ "END";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}