# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?:IF|ELSE) ([A-Z]+) -> ([A-Z]+) IN\(( (?:\"[A-Z0-9]{2}\"(?:[, ])*)+)\)(?: +)THEN ([A-Z0-9\-]+) =\"([A-Z]+)\""
test_str = ("IF KNVV -> KDGRP IN( \"EK\", \"ES\" ) THEN KNA1-SORTL =\"KA\"\n"
"ELSE KNVV -> KDGRP IN( \"EL\", \"E3\", \"E5\", \"E7\", \"E2\", \"EF\" ) THEN KNA1-SORTL =\"IN\"\n"
"ELSE KNVV -> KDGRP IN( \"EX\", \"EU\", \"EV\", \"ET\", \"EW\" ) THEN KNA1-SORTL =\"CA\"\n"
"END")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.