using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?P<qui>\b\w*in\b).*(?P<quand>\bd\w*e\b)";
string input = @"on m'a dit que Kevin passerait en coups de vent dimanche après-midi";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}