import re
regex = re.compile(r"(?P<qui>\b\w*in\b).*(?P<quand>\bd\w*e\b)")
test_str = "on m'a dit que Kevin passerait en coups de vent dimanche après-midi"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")