// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?P<qui>\b\w*in\b).*(?P<quand>\bd\w*e\b)").unwrap();
let string = "on m'a dit que Kevin passerait en coups de vent dimanche après-midi";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}