re = /(?P<qui>\b\w*in\b).*(?P<quand>\bd\w*e\b)/
str = 'on m\'a dit que Kevin passerait en coups de vent dimanche après-midi'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end