package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?P<qui>\b\w*in\b).*(?P<quand>\bd\w*e\b)`)
var str = `on m'a dit que Kevin passerait en coups de vent dimanche après-midi`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}