$re = '/(?P<qui>\b\w*in\b).*(?P<quand>\bd\w*e\b)/';
$str = 'on m\'a dit que Kevin passerait en coups de vent dimanche après-midi';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);