use strict;
my $str = 'https://example.com/?keywords=test
';
my $regex = qr/\=./mp;
my $subst = '\\U$0';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";