re = /\=./m
str = 'https://example.com/?keywords=test
'
subst = '\\U$0'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result