#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?:^<p class="text_formal">|\G)\K\s*(\S+)"
Local $sString = "<p class="test_formal"> This is my text <em>and all of this</em> I have to go home .</p>" & @CRLF & _
"" & @CRLF & _
"<p class="test_formal"> This is my text <em>and all of this</em> I have to go home .</p>" & @CRLF & _
"" & @CRLF & _
"<p class="test_Bla Blal"> This is my text <em>and all of this</em> I have to go home .</p>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")