import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:^<p class=\"text_formal\">|\\G)\\K\\s*(\\S+)";
final String string = "<p class=\"test_formal\"> This is my text <em>and all of this</em> I have to go home .</p>\n\n"
+ "<p class=\"test_formal\"> This is my text <em>and all of this</em> I have to go home .</p>\n\n"
+ "<p class=\"test_Bla Blal\"> This is my text <em>and all of this</em> I have to go home .</p>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}