re = /(?:^<p class="text_formal">|\G)\K\s*(\S+)/m
str = '<p class="test_formal"> This is my text <em>and all of this</em> I have to go home .</p>
<p class="test_formal"> This is my text <em>and all of this</em> I have to go home .</p>
<p class="test_Bla Blal"> This is my text <em>and all of this</em> I have to go home .</p>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end