using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:^<p class=""text_formal"">|\G)\K\s*(\S+)";
string input = @"<p class=""test_formal""> This is my text <em>and all of this</em> I have to go home .</p>
<p class=""test_formal""> This is my text <em>and all of this</em> I have to go home .</p>
<p class=""test_Bla Blal""> This is my text <em>and all of this</em> I have to go home .</p>";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}