$re = '/(?:^<p class="text_formal">|\G)\K\s*(\S+)/m';
$str = '<p class="test_formal"> This is my text <em>and all of this</em> I have to go home .</p>
<p class="test_formal"> This is my text <em>and all of this</em> I have to go home .</p>
<p class="test_Bla Blal"> This is my text <em>and all of this</em> I have to go home .</p>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);