use strict;
my $str = '<p class="test_formal"> This is my text <em>and all of this</em> I have to go home .</p>
<p class="test_formal"> This is my text <em>and all of this</em> I have to go home .</p>
<p class="test_Bla Blal"> This is my text <em>and all of this</em> I have to go home .</p>';
my $regex = qr/(?:^<p class="text_formal">|\G)\K\s*(\S+)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}