package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)^(?:[A-Za-z]+ )*china(?:[ -][A-Za-z]+)*$`)
var str = `CHINA
CHINA ROM
CHINA WAREHOUSE
CHINA-WAREHOUSE
CHINA-ROM
dsa china
CHINALOCAL
CHINAOO #No`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}