re = /^(?:[A-Za-z]+ )*china(?:[ -][A-Za-z]+)*$/mi
str = 'CHINA
CHINA ROM
CHINA WAREHOUSE
CHINA-WAREHOUSE
CHINA-ROM
dsa china
CHINALOCAL
CHINAOO #No'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end