$re = '/^(?:[A-Za-z]+ )*china(?:[ -][A-Za-z]+)*$/mi';
$str = 'CHINA
CHINA ROM
CHINA WAREHOUSE
CHINA-WAREHOUSE
CHINA-ROM
dsa china
CHINALOCAL
CHINAOO #No';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);