import re
regex = re.compile(r"^(?:[A-Za-z]+ )*china(?:[ -][A-Za-z]+)*$", flags=re.MULTILINE | re.IGNORECASE)
test_str = ("CHINA\n"
"CHINA ROM\n"
"CHINA WAREHOUSE\n"
"CHINA-WAREHOUSE\n"
"CHINA-ROM\n"
"dsa china\n"
"CHINALOCAL\n"
"CHINAOO #No")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")