using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(""filterType"":\h+""LOT_SIZE"",(?:\R\h+""[^""]+"":\h+""[^""]+"",?){3})(?:\R\h+""[^""]+"":\h+""[^""]+"",?){3}";
string substitution = @"$1";
string input = @"""symbol"": ""ETHBTC"",
""filterType"": ""LOT_SIZE"",
""minQty"": ""0.00100000"",
""maxQty"": ""100000.00000000"",
""stepSize"": ""0.00100000""
""minQty"": ""0.00000000"",
""maxQty"": ""9201.00570633"",
""stepSize"": ""0.00000000""
""symbol"": ""LTCBTC"",
""filterType"": ""LOT_SIZE"",
""minQty"": ""0.01000000"",
""maxQty"": ""100000.00000000"",
""stepSize"": ""0.01000000""
""minQty"": ""0.00000000"",
""maxQty"": ""33144.83294363"",
""stepSize"": ""0.00000000""";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}