import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\"filterType\":\\h+\"LOT_SIZE\",(?:\\R\\h+\"[^\"]+\":\\h+\"[^\"]+\",?){3})(?:\\R\\h+\"[^\"]+\":\\h+\"[^\"]+\",?){3}";
final String string = "\"symbol\": \"ETHBTC\",\n"
+ " \"filterType\": \"LOT_SIZE\",\n"
+ " \"minQty\": \"0.00100000\",\n"
+ " \"maxQty\": \"100000.00000000\",\n"
+ " \"stepSize\": \"0.00100000\"\n"
+ " \"minQty\": \"0.00000000\",\n"
+ " \"maxQty\": \"9201.00570633\",\n"
+ " \"stepSize\": \"0.00000000\"\n"
+ "\"symbol\": \"LTCBTC\",\n"
+ " \"filterType\": \"LOT_SIZE\",\n"
+ " \"minQty\": \"0.01000000\",\n"
+ " \"maxQty\": \"100000.00000000\",\n"
+ " \"stepSize\": \"0.01000000\"\n"
+ " \"minQty\": \"0.00000000\",\n"
+ " \"maxQty\": \"33144.83294363\",\n"
+ " \"stepSize\": \"0.00000000\"";
final String subst = "$1";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}