// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)("filterType":\h+"LOT_SIZE",(?:\R\h+"[^"]+":\h+"[^"]+",?){3})(?:\R\h+"[^"]+":\h+"[^"]+",?){3}"#).unwrap();
let string = "\"symbol\": \"ETHBTC\",
\"filterType\": \"LOT_SIZE\",
\"minQty\": \"0.00100000\",
\"maxQty\": \"100000.00000000\",
\"stepSize\": \"0.00100000\"
\"minQty\": \"0.00000000\",
\"maxQty\": \"9201.00570633\",
\"stepSize\": \"0.00000000\"
\"symbol\": \"LTCBTC\",
\"filterType\": \"LOT_SIZE\",
\"minQty\": \"0.01000000\",
\"maxQty\": \"100000.00000000\",
\"stepSize\": \"0.01000000\"
\"minQty\": \"0.00000000\",
\"maxQty\": \"33144.83294363\",
\"stepSize\": \"0.00000000\"";
let substitution = "$1";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}