package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)\b(?:(?P<g0>ERP)|(?P<g1>Gap))\b`)
var str = `ERP is integral part of GAP, so erp can never be ignored, ErP!`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}