$re = '/\b(?:(?P<g0>ERP)|(?P<g1>Gap))\b/i';
$str = 'ERP is integral part of GAP, so erp can never be ignored, ErP!';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);