import re
regex = re.compile(r"\b(?:(?P<g0>ERP)|(?P<g1>Gap))\b", flags=re.IGNORECASE)
test_str = "ERP is integral part of GAP, so erp can never be ignored, ErP!"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")