// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?i)\b(?:(?P<g0>ERP)|(?P<g1>Gap))\b").unwrap();
let string = "ERP is integral part of GAP, so erp can never be ignored, ErP!";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}