const regex = new RegExp('\\b(?:(?P<g0>ERP)|(?P<g1>Gap))\\b', 'gi')
const str = `ERP is integral part of GAP, so erp can never be ignored, ErP!`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}