re = /\b(?:(?P<g0>ERP)|(?P<g1>Gap))\b/i
str = 'ERP is integral part of GAP, so erp can never be ignored, ErP!'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end