const regex = /,\s*(?=\w+=)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp(',\\s*(?=\\w+=)', 'gm')
const str = `a=1, b=2, c=3
foo=bar, url=http://city.com/Boston, MA US, is_test=false
a=1, b="2,3", c=3
foo="bar, harbor", url=http://city.com/start_city=Boston, MAUS&end_city=New York, NY US, is_test=false`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}