$re = '/,\s*(?=\w+=)/m';
$str = 'a=1, b=2, c=3
foo=bar, url=http://city.com/Boston, MA US, is_test=false
a=1, b="2,3", c=3
foo="bar, harbor", url=http://city.com/start_city=Boston, MAUS&end_city=New York, NY US, is_test=false';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);