import re
regex = re.compile(r",\s*(?=\w+=)", flags=re.MULTILINE)
test_str = ("a=1, b=2, c=3\n"
"foo=bar, url=http://city.com/Boston, MA US, is_test=false\n"
"a=1, b=\"2,3\", c=3\n"
"foo=\"bar, harbor\", url=http://city.com/start_city=Boston, MAUS&end_city=New York, NY US, is_test=false")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")