use strict;
my $str = 'a=1, b=2, c=3
foo=bar, url=http://city.com/Boston, MA US, is_test=false
a=1, b="2,3", c=3
foo="bar, harbor", url=http://city.com/start_city=Boston, MAUS&end_city=New York, NY US, is_test=false';
my $regex = qr/,\s*(?=\w+=)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}