re = /,\s*(?=\w+=)/m
str = 'a=1, b=2, c=3
foo=bar, url=http://city.com/Boston, MA US, is_test=false
a=1, b="2,3", c=3
foo="bar, harbor", url=http://city.com/start_city=Boston, MAUS&end_city=New York, NY US, is_test=false'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end