#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)relay=(?<dest_domain>.*\w+)[\.\s]+\[(?<dest_ip>[^\]]+)"
Local $sString = "relay=user@buttercup-games.com. [1.1.1.1]" & @CRLF & _
"relay=user@buttercup-games.com [1.1.1.1]" & @CRLF & _
"relay=user@buttercup-games.com.[1.1.1.1]"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")