package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)relay=(?<dest_domain>.*\w+)[\.\s]+\[(?<dest_ip>[^\]]+)`)
var str = `relay=user@buttercup-games.com. [1.1.1.1]
relay=user@buttercup-games.com [1.1.1.1]
relay=user@buttercup-games.com.[1.1.1.1]`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}