// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)relay=(?<dest_domain>.*\w+)[\.\s]+\[(?<dest_ip>[^\]]+)").unwrap();
let string = "relay=user@buttercup-games.com. [1.1.1.1]
relay=user@buttercup-games.com [1.1.1.1]
relay=user@buttercup-games.com.[1.1.1.1]";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}