import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "relay=(?<dest_domain>.*\\w+)[\\.\\s]+\\[(?<dest_ip>[^\\]]+)";
final String string = "relay=user@buttercup-games.com. [1.1.1.1]\n"
+ "relay=user@buttercup-games.com [1.1.1.1]\n"
+ "relay=user@buttercup-games.com.[1.1.1.1]";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}