re = /relay=(?<dest_domain>.*\w+)[\.\s]+\[(?<dest_ip>[^\]]+)/m
str = 'relay=user@buttercup-games.com. [1.1.1.1]
relay=user@buttercup-games.com [1.1.1.1]
relay=user@buttercup-games.com.[1.1.1.1]'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end