$re = '/relay=(?<dest_domain>.*\w+)[\.\s]+\[(?<dest_ip>[^\]]+)/m';
$str = 'relay=user@buttercup-games.com. [1.1.1.1]
relay=user@buttercup-games.com [1.1.1.1]
relay=user@buttercup-games.com.[1.1.1.1]';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);