using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"`([\w+ ]*)`";
string input = @"<#346283347234774> **Useless text that I want to remove**
more useless text it is useless, so useless.
`potato`, `boxes`, `christmas tree`";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}