re = /`([\w+ ]*)`/
str = '<#346283347234774> **Useless text that I want to remove**
more useless text it is useless, so useless.
`potato`, `boxes`, `christmas tree`'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end