import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "`([\\w+ ]*)`";
final String string = "<#346283347234774> **Useless text that I want to remove**\n"
+ "more useless text it is useless, so useless.\n"
+ "`potato`, `boxes`, `christmas tree`";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}