const regex = new RegExp('`([\\w+ ]*)`', 'g')
const str = `<#346283347234774> **Useless text that I want to remove**
more useless text it is useless, so useless.
\`potato\`, \`boxes\`, \`christmas tree\``;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}