import re
regex = re.compile(r"`([\w+ ]*)`")
test_str = ("<#346283347234774> **Useless text that I want to remove**\n"
"more useless text it is useless, so useless.\n"
"`potato`, `boxes`, `christmas tree`")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")